Press "Enter" to skip to content

Tag: UF

Poorly displayed poll results

I've begun searching for news articles that either use statistics incorrectly (misunderstanding what a study means, making bogus claims, etc.), present data exceptionally poorly (misleading graphs), or other offenses against numeracy. I wasn't expecting to find much on Day 1. I was wrong.

The Alligator (UF's 'unofficial' school newspaper) has a daily online poll. Monday's question was "Have you eaten pizza this month?" with the results displayed as percentages and a bar chart. For example:

Online poll results from The Alligator on 24 September 2012.

A few problems:

  1. The responses are given numerically only as a percentage with no indication of sample size (either by category or total responses). We are left to guess the sample size from the bar chart.
  2. The bar chart doesn't show 0 and goes so far as to not display the observations from the "no" respondents! Based on the percentages and guessing that "yes" had 61 respondents (it is hard to tell), it seems like "no" should have 11 which is certainly not what the graph appears to show.
  3. It isn't visible in the above chart, but on different pages of The Alligator the poll results showed slightly different numbers  (85%/15% (picture) and 84%/16% (picture)). I could click back and forth between the pages and the numbers didn't change.
Overall, the online poll (powered by amCharts.com apparently) that The Alligator hosts does a woefully inadequate job of displaying the results.
Leave a Comment

Quite a few minor issues today

I've been doing a lot of writing in Microsoft Word lately (there are others working on the same document and LibreOffice Writer can't seem to get it right), so I've been living in Windows-world. Yesterday I needed to access an R package that is UNIX-only apparently (heR.Misc - really? No Windows binaries?) and was greeted by Scientific Linux with some updates to take care of. Most of the updates installed fine, but five did not. The five that did not were all related to Qpid (packages like qpid-cpp-client). These could not be installed because yum could not resolve some dependency issues. Apparently the issue was that these updates were related in some way to the matahari package, which was deprecated by Red Hat (according to this forum post at least). A quick sudo yum remove matahari in the terminal and the updates installed correctly.

I figured while I was updating software that I would try to get an Aero Snap-like feature working in Linux.  As much as I like the stability of Linux, I dislike the lack of some should-be-standard features in GNOME. In Windows 7, there are some great features like Aero Snap (automatically half-maximize windows) and windows grouped on the taskbar. CompizFusion can... somewhat perform these features, but not with the polish and consistency that I've come to expect.

I just care about my computer supporting my productivity, and I am therefore not attached to any particular window environment. KDE 4 seems to have implemented some of these features without the use of add-ons, so I figured that I would give it a try. However, installing KDE using YUM wasn't immediately obvious. Searching for "kde" resulted in tons of packages, but none seemed to be a wrapper for the entire environment. Eventually I went to the command line and executed (as root):

yum groupinstall "KDE desktop"

However, I should have realized that Scientific Linux doesn't have the latest, greatest packages. The KDE that was installed was version 4.3 and... didn't do what I wanted it to. I promptly switched back to GNOME and started playing around with CompizFusion.

Long story short, I got frustrated and gave up for the time being. I am determined to get this to work, but I don't have the time to devote to it right this second. I think this is where things went wrong: I wanted to uninstall KDE and did

yum groupremove "KDE desktop"

which uninstalled all KDE-related packages and not just the ones that had been installed above (I had previously installed some packages like kdegraphics which contains Okular (a great PDF reader)). While I would like to figure out how to remove an entire group  except for certain packages, that's something to solve later. No big deal, I didn't use them much and could always add them back later. I rebooted my computer to complete some updates and...

No internet when it came back. The GNOME panel icon was just... gone. Now, my first instinct was to search the internet for related issues. I was able to get online by plugging in an ethernet cable and running, as root,

ifconfig eth0 up
dhclient eth0

This gave me wired internet, though Yum Extender didn't want to believe it had internet. I ended up having to run from the terminal

yumex --root

to be able to install packages.

Most of the resources I found related to Ubuntu which can be rather different from Scientific Linux/CentOS/RHEL. I tried to see if the network manager was still installed by running


[Doug@FLASHMAN-SL ~]$ service network-manager status
network-manager: unrecognized service

Seems like a problem... except the network manager is not called network-manager in Scientific Linux. It is actually called NetworkManager.


[Doug@FLASHMAN-SL ~]$ service NetworkManager status
NetworkManager (pid  2077) is running...

I spent way too long reinstalling NetworkManager when that was never my issue. What it turned out to be was the program nm-applet was missing (uninstalled at some point), and I just needed to (re)install the package NetworkManager-gnome.

That was a headache that was mostly my fault, but the lack of solid documentation (and vague search terms like "gnome internet icon missing") made this difficult to figure out. Maybe putting all of these search terms in one place will help other people.

As an aside, my school (UF) now offers Red Hat Enterprise Linux to students... and I am toying with the idea of switching from Scientific Linux to RHEL. However, UF is running RHEL 6.1 and I'm running SL 6.2, and I would prefer to not do a clean install. Unsurprisingly, Red Hat does not support cross-grading (I asked), and I don't want to fiddle with a simultaneous cross/downgrade. Though I must say, the support would be nice for situations like this...

Leave a Comment